+ Reply to Thread
Results 1 to 5 of 5

Thread: Pre-amp problems

  1. #1
    Join Date: Jan 2020

    Location: Sheffield

    Posts: 8
    I'm Evie.

    Default Pre-amp problems

    At present I have a pair of Naim Nap 155XS power amplifiers driving some Monitor Audio Gold Reference 60s. I am using a Conrad Johnson PVL14 as the pre-amplifier but the noise floor is quit high, the bass (20-40Hz) isnít too clever and it has been eating its way through valves (when really they should last a lot longer).
    What would anybody recommend as a new pre-amp?

  2. #2
    Join Date: Apr 2009

    Location: Near Saffron Walden, Essex

    Posts: 6,687
    I'm Dave.

    Default

    Budget ?

  3. #3
    Join Date: Jan 2020

    Location: Sheffield

    Posts: 8
    I'm Evie.

    Default Pre-amp problems (continued)

    At present I have a pair of Naim Nap 155XS power amplifiers driving some Monitor Audio Gold Reference 60s. I am using a Conrad Johnson PVL14 as the pre-amplifier but the noise floor is quit high, the bass (20-40Hz) isnít too clever and it has been eating its way through valves (when really they should last a lot longer).
    What would anybody recommend as a new pre-amp?

    Budget would be £2,500 limit.

    I am happy to buy second hand stuff.

  4. #4
    Join Date: Oct 2012

    Location: The Black Country

    Posts: 5,252
    I'm Alan.

    Default

    It does sound like your Conrad Johnson isn't quite as it should be, small signal valves should last for ages.

    Is it a 220V version, it could be that the voltages are too high when used on UK mains. I could take a look at it and see if you wish.

  5. #5
    Join Date: Oct 2012

    Location: West London

    Posts: 143
    I'm Steve.

    Default

    Try some Rothwell attenuators plugged in at the power amp end.

    I had the same problem as you. I have a VTL valve pre and XTC transistor power amp and the noise floor was high.

    I thought about replacing the pre but since I put the attenuators in it sounds so much better that I am now happy with my set up.

    Saved me a packet.

    Don't know why your valves are failing though. The 60's are lovely speakers.
    Thorens TD550, Ortofon 12", Ortofon Jubilee or Koetsu Black; Rothwell MCL SUT, VTL 2.5 pre, XTC POW 1 power; Naim CD5x; KEF Reference 3.2's; Van den Hul interconnects and speaker cables.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •