+ Reply to Thread
Results 1 to 5 of 5

Thread: Rega Planar 2 Issues

  1. #1
    Join Date: Oct 2016

    Location: London

    Posts: 231
    I'm David.

    Default Rega Planar 2 Issues

    Hi All,
    A friend reports the following problems with her Rega Planar 2:
    -Once the turntable is turned on, it plays perfectly for about 20-40 minutes max
    -After that time, the turntable will intermittently loose speed for about 2-3 seconds, and then it will come back up to speed
    -This pattern continues and becomes more frequent (although completely random) the longer the turntable is on. But it always seems to come up to speed in the intervening periods.
    -At it's worst, the intervals between the slowdowns come about every 30 seconds.

    It's a Rega Planar 2, around 15-20 years old

    I havn't seen it and it sounds like the motor is knackered but has anyone else experienced it? If it is the motor where's the best place to get spares?

    Thanks!

  2. #2
    Join Date: May 2013

    Location: Rotherham

    Posts: 572
    I'm steve.

    Default

    Best thing to do is to call Rega on 01702-333071 and speak to a member of their tech team.


    Sent from my iPad using Tapatalk

  3. #3
    Join Date: Apr 2012

    Location: Southall, West London

    Posts: 44,325
    I'm Geoff.

    Default

    I expect there'll be members here who have Rega spares if needed.
    Official consultant wigmaker to Ant & Dec

  4. #4
    Join Date: Oct 2016

    Location: London

    Posts: 231
    I'm David.

    Default

    If anybody has a spare motor do let me know! Cheers

  5. #5
    Join Date: Jan 2009

    Location: Deleted

    Posts: 6,674
    I'm Deleted.

    Default

    I would be very surprised if you needed a new motor as they are extremely reliable. Two issues spring to mind. The first is that the drive pulley is superglued to the motor shaft and it has been known for this to become loose over time. The second is the phasing capacitor to the motor which may need replacing. However, there is a good chance it is the first issue. Buy a new belt, clean the drive surfaces put a drop of glue where the drive pulley mates with the motor spindle.
    Account Deleted

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •