+ Reply to Thread
Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: LP12 & Denon DL 304

  1. #21
    Join Date: May 2018

    Location: Woking

    Posts: 507
    I'm Chris.

    Default

    Are your Croft's sorted now Karl??
    System 1: - Amp - Musical Paradise MP-701 - Neurochrome 686
    - Source: Linn LP12 (AT-OC9XEN) - D-Klimo LAR copy - Novafidelity X12 - Musical Paradise MP-D1 mkII -
    - Speakers: Cambridge Acoustic "Grand Master Evolution" Subs: - REL T3's -

    System 2 - Amp: Marantz 1060
    - Source: Audio Technica LP5 - EAR834p clone - Pioneer N-30K - Musical Paradise MP-D1 -
    - Speakers: Loth X BS1's - Sub: REL T3 -

    System 3: - Amp: Custom N-core 300B SEP -
    - Source: Cambridge Audio Stream Magic 6 - Topping E30 -
    - Speakers: Quad 63's -

  2. #22
    Join Date: Mar 2017

    Location: Melbourne

    Posts: 356
    I'm Karl.

    Default

    Quote Originally Posted by Opti-cal View Post
    Are your Croft's sorted now Karl??
    Yes all sorted thanks chris, it was a failed regulator that heats the filament so not too hard on the wallet. Still enjoying the new cart?


    Sent from my iPhone using Tapatalk
    CTC Classic 301 , SPH bearing and Hanze Hifi HAT CPS-2 all analogue power supply / Tenuto mat / custom Panzerholz and Kewasinga articulating plinth / Track audio isolation feet / Reed tonearm / Audio Technica ART 9 / Whest 2.2 phonostage / BigBottle mk3 hybrid phonostage with Clarity cap CMR and NOS Telefunkens valves / Croft 25RLS preamp with NOS RCA valves / Croft 7R monoblocks with NOS RCA valves/ Spendor SP2/3R2 / Chord cobra 3 interconnects / Merlin Scorpion mains block / Rhodium mains cables / QED signature speaker cable / Marantz CD DAC /Atacama Equinox rack

  3. #23
    Join Date: May 2018

    Location: Woking

    Posts: 507
    I'm Chris.

    Default

    Quote Originally Posted by Bigbird View Post
    Yes all sorted thanks chris, it was a failed regulator that heats the filament so not too hard on the wallet. Still enjoying the new cart?


    Sent from my iPhone using Tapatalk
    Yup, I'm actually running it in a different system as my current main rig is not too well . . .

    Its partnered with a single input 300b parallel configured amp and some Loth X horn speakers. Its a refreshing little change from KT88's and Quads.

    Glad yours is sorted, maybe one day we'll both have our systems sorted at the same time?!?! Even if its just for 5 minutes!
    System 1: - Amp - Musical Paradise MP-701 - Neurochrome 686
    - Source: Linn LP12 (AT-OC9XEN) - D-Klimo LAR copy - Novafidelity X12 - Musical Paradise MP-D1 mkII -
    - Speakers: Cambridge Acoustic "Grand Master Evolution" Subs: - REL T3's -

    System 2 - Amp: Marantz 1060
    - Source: Audio Technica LP5 - EAR834p clone - Pioneer N-30K - Musical Paradise MP-D1 -
    - Speakers: Loth X BS1's - Sub: REL T3 -

    System 3: - Amp: Custom N-core 300B SEP -
    - Source: Cambridge Audio Stream Magic 6 - Topping E30 -
    - Speakers: Quad 63's -

  4. #24
    Join Date: Mar 2017

    Location: Melbourne

    Posts: 356
    I'm Karl.

    Default

    Oh no whatís happened now?

    These bloody hifiís are a pain the arse arent they . We spend small fortunes on them and half the time they are either broken or were not happy with them .


    Sent from my iPhone using Tapatalk
    CTC Classic 301 , SPH bearing and Hanze Hifi HAT CPS-2 all analogue power supply / Tenuto mat / custom Panzerholz and Kewasinga articulating plinth / Track audio isolation feet / Reed tonearm / Audio Technica ART 9 / Whest 2.2 phonostage / BigBottle mk3 hybrid phonostage with Clarity cap CMR and NOS Telefunkens valves / Croft 25RLS preamp with NOS RCA valves / Croft 7R monoblocks with NOS RCA valves/ Spendor SP2/3R2 / Chord cobra 3 interconnects / Merlin Scorpion mains block / Rhodium mains cables / QED signature speaker cable / Marantz CD DAC /Atacama Equinox rack

  5. #25
    Join Date: May 2018

    Location: Woking

    Posts: 507
    I'm Chris.

    Default

    Well . . . swapped my aging pair of Quad 63's with a fading treble panel for a pair of recently refurbished and much newer ones. Fully tested them at the sellers house and they were silent and sounding great. Drove like Miss Daisy with them wrapped up in a duvet to transport them home . . . you can probably tell where this is going.

    Turned them on and one has a rattle on resonant bass notes and a slight mains hum and the other one has a ticking bass panel.

    I literally have never had any problems transporting them (and less carefully) in the past.

    Unfortunately the issues are audible from my listening position so completely ruins my listening experience!!!

    Luckily I think the issue (rattling on bass notes) is the dust membrane needing re-stretching which can be done with a heat gun and the ticking panel might improve after a few days of "settling in" and acclimatising again after de-charging.

    I had a bloomin lovely sounding system for a couple of months and was really enjoying it. But its like its always on a bloody knife edge, what with all tubes and electrostats its always going to be maintenance and potentially things going wrong all the time.

    That's before I even get started on TT's and grounding issues . . . .

    Wonder why we bother sometimes . . . (Well I do know why we bother but as you say, PITA!)
    System 1: - Amp - Musical Paradise MP-701 - Neurochrome 686
    - Source: Linn LP12 (AT-OC9XEN) - D-Klimo LAR copy - Novafidelity X12 - Musical Paradise MP-D1 mkII -
    - Speakers: Cambridge Acoustic "Grand Master Evolution" Subs: - REL T3's -

    System 2 - Amp: Marantz 1060
    - Source: Audio Technica LP5 - EAR834p clone - Pioneer N-30K - Musical Paradise MP-D1 -
    - Speakers: Loth X BS1's - Sub: REL T3 -

    System 3: - Amp: Custom N-core 300B SEP -
    - Source: Cambridge Audio Stream Magic 6 - Topping E30 -
    - Speakers: Quad 63's -

  6. #26
    Join Date: Mar 2017

    Location: Melbourne

    Posts: 356
    I'm Karl.

    Default

    Quote Originally Posted by Opti-cal View Post
    Well . . . swapped my aging pair of Quad 63's with a fading treble panel for a pair of recently refurbished and much newer ones. Fully tested them at the sellers house and they were silent and sounding great. Drove like Miss Daisy with them wrapped up in a duvet to transport them home . . . you can probably tell where this is going.

    Turned them on and one has a rattle on resonant bass notes and a slight mains hum and the other one has a ticking bass panel.

    I literally have never had any problems transporting them (and less carefully) in the past.

    Unfortunately the issues are audible from my listening position so completely ruins my listening experience!!!

    Luckily I think the issue (rattling on bass notes) is the dust membrane needing re-stretching which can be done with a heat gun and the ticking panel might improve after a few days of "settling in" and acclimatising again after de-charging.

    I had a bloomin lovely sounding system for a couple of months and was really enjoying it. But its like its always on a bloody knife edge, what with all tubes and electrostats its always going to be maintenance and potentially things going wrong all the time.

    That's before I even get started on TT's and grounding issues . . . .

    Wonder why we bother sometimes . . . (Well I do know why we bother but as you say, PITA!)
    Ah mate what a pain in the arse!! Do you think they were knocked about on route home or a dodgy restoration job?

    Any luck in fixing any of the issues yet?


    Sent from my iPhone using Tapatalk
    CTC Classic 301 , SPH bearing and Hanze Hifi HAT CPS-2 all analogue power supply / Tenuto mat / custom Panzerholz and Kewasinga articulating plinth / Track audio isolation feet / Reed tonearm / Audio Technica ART 9 / Whest 2.2 phonostage / BigBottle mk3 hybrid phonostage with Clarity cap CMR and NOS Telefunkens valves / Croft 25RLS preamp with NOS RCA valves / Croft 7R monoblocks with NOS RCA valves/ Spendor SP2/3R2 / Chord cobra 3 interconnects / Merlin Scorpion mains block / Rhodium mains cables / QED signature speaker cable / Marantz CD DAC /Atacama Equinox rack

  7. #27
    Join Date: May 2018

    Location: Woking

    Posts: 507
    I'm Chris.

    Default

    Quote Originally Posted by Bigbird View Post
    Ah mate what a pain in the arse!! Do you think they were knocked about on route home or a dodgy restoration job?

    Any luck in fixing any of the issues yet?


    Sent from my iPhone using Tapatalk
    Must have happened on route as the seller, lets just say would have no need to "get rid" of or do a rushed job on restoring. He probably had 30k's worth in one room. A big dedicated listening room slightly larger than the downstairs of my house . . . . plus he was a genuine honest guy to boot and has since offered to help me fix them, which he had no obligation to do.

    Just bad luck as I was super careful with them.

    Luckily with some pounding bass tracks run through them the rattling does seem to have subsided. I think it is a dust membrane which apparently, when it goes, does a pretty good impression of an angry bee on bass notes. It's no longer audible from my listening position, which is nice.

    Additionally the other speaker has "calmed" slightly too. Ticking is less audible and above all the music sounds as it should. That's the main thing.

    As I'm moving soon I'll get them into their new home and then set about fixing them properly unless they magically heal after another move . . . sounds stupid but this has actually happened to me before . . . .

    Cheers Karl.
    System 1: - Amp - Musical Paradise MP-701 - Neurochrome 686
    - Source: Linn LP12 (AT-OC9XEN) - D-Klimo LAR copy - Novafidelity X12 - Musical Paradise MP-D1 mkII -
    - Speakers: Cambridge Acoustic "Grand Master Evolution" Subs: - REL T3's -

    System 2 - Amp: Marantz 1060
    - Source: Audio Technica LP5 - EAR834p clone - Pioneer N-30K - Musical Paradise MP-D1 -
    - Speakers: Loth X BS1's - Sub: REL T3 -

    System 3: - Amp: Custom N-core 300B SEP -
    - Source: Cambridge Audio Stream Magic 6 - Topping E30 -
    - Speakers: Quad 63's -

+ Reply to Thread
Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •