+ Reply to Thread
Page 8 of 8 FirstFirst ... 678
Results 71 to 73 of 73

Thread: Developing the MA100 amplifier

  1. #71
    Join Date: May 2016

    Location: Notts

    Posts: 2,501
    I'm Geoff.

    Default

    Quote Originally Posted by Radford Revival View Post
    Approaching first power / fire / smoke!!
    Surely this merits a video and not just pictures!

  2. #72
    Join Date: Apr 2012

    Location: South West of England

    Posts: 307
    I'm Will.

    Default

    Quote Originally Posted by Sherwood View Post
    Surely this merits a video and not just pictures!


    The PSU board has proven to work - the active ripple killer circuit works far better than it has any right to. The screen supply is also functioning correctly.

    I'm actually fairly certain the amplifier will work - the only question now is dialling in the feedback. Aside from some tweaks that are likely to arise I would tentatively call the design complete.

    What remains is correcting the various layout mistakes on the boards (inevitable) and finishing the design of the casework. There may be a few little gremlins in the circuit design but I don't think there's much left hidden - the design has been extensively modelled and the previous version had proved most of the concepts already.
    Radford Revival
    www.radfordrevival.co.uk

  3. #73
    Join Date: Apr 2012

    Location: South West of England

    Posts: 307
    I'm Will.

    Default

    It works! I blew it up a couple of times in the process and have a large list of small errors to correct, but aside from dialling the feedback, everything is now working!
    Radford Revival
    www.radfordrevival.co.uk

+ Reply to Thread
Page 8 of 8 FirstFirst ... 678

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •