+ Reply to Thread
Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 54

Thread: Jbl le8t-2 help !!!

  1. #11
    Join Date: May 2016

    Location: Milton Keynes

    Posts: 1,088
    I'm Andrew.

    Default

    Quote Originally Posted by walpurgis View Post
    I doubt it, unless you were rather brutal with the cones. Try remaking the soldered connections at the terminals where the lead out wires attach if you can reach them.
    Do you mean here ?


    Sent from my iPhone using Tapatalk

  2. #12
    Join Date: May 2016

    Location: Milton Keynes

    Posts: 1,088
    I'm Andrew.

    Default

    Nop sweet fa


    Sent from my iPhone using Tapatalk

  3. #13
    Join Date: Apr 2012

    Location: Southall, West London

    Posts: 35,202
    I'm Geoff.

    Default

    Quote Originally Posted by andyrlb View Post
    Do you mean here ?
    Yeah. Although that looks perfectly OK. If all the soldering at the terminals looks like that leave them alone.

  4. #14
    Join Date: May 2016

    Location: Milton Keynes

    Posts: 1,088
    I'm Andrew.

    Default

    Good here too ....


    Sent from my iPhone using Tapatalk

  5. #15
    Join Date: May 2016

    Location: Milton Keynes

    Posts: 1,088
    I'm Andrew.

    Default

    Well it looks like theyíre knackered ( somehow) and that makes refurbishment of the JBL Aquarius uneconomical, I am truly gutted
    One consolation is that the radfords only need a tweeter .


    Sent from my iPhone using Tapatalk

  6. #16
    Join Date: May 2016

    Location: Milton Keynes

    Posts: 1,088
    I'm Andrew.

    Default

    I just tried the other one and I placed the meter probes directly on the wires from the terminals and wiggled them and THEY WORKED....for a few seconds


    Sent from my iPhone using Tapatalk

  7. #17
    Join Date: Apr 2012

    Location: Southall, West London

    Posts: 35,202
    I'm Geoff.

    Default

    Hmm. In that case, do remake the soldered joints. Just get them hot enough to melt the solder, don't pull the wires out. Then test them again.

  8. #18
    Join Date: May 2016

    Location: Milton Keynes

    Posts: 1,088
    I'm Andrew.

    Default

    Must have been the meter probes as I canít replicate it now


    Sent from my iPhone using Tapatalk

  9. #19
    Join Date: May 2016

    Location: Milton Keynes

    Posts: 1,088
    I'm Andrew.

    Default

    Nowt !!


    Sent from my iPhone using Tapatalk

  10. #20
    Join Date: May 2016

    Location: Milton Keynes

    Posts: 1,088
    I'm Andrew.

    Default Jbl le8t-2 help !!!

    Last resort ?
    Dust cap off ?


    Sent from my iPhone using Tapatalk

+ Reply to Thread
Page 2 of 6 FirstFirst 1234 ... LastLast



 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •