+ Reply to Thread
Page 5 of 5 FirstFirst ... 345
Results 41 to 47 of 47

Thread: Radford TT100 - the saga begins...?

  1. #41
    Join Date: Oct 2016

    Location: London

    Posts: 47
    I'm David.

    Default

    Quote Originally Posted by nickbaba View Post
    So... there is news, and it's not all bad!
    The scariest part was that apparently the power supply board had come completely loose inside and could have shorted 600v into the metal case if it were plugged in...

    Anyway David gradually introduced voltage up to full power and all went well - he even said it doesn't sound too bad... at least for a first test.

    So things are looking very hopeful.
    Nick's post is spot on in that the sound quality is very promising. A lot of lazy bass power and dynamics evident but the valves were new so it would be unfair to judge the remainder of the frequency range too critically. But in addition to the loose /Blue Tack mounted high voltage components the earth wire in the plug had come adrift, so any short could have resulted in a live chassis. And 600v could be fatal........

  2. #42
    Join Date: Oct 2016

    Location: London

    Posts: 47
    I'm David.

    Default

    Quote Originally Posted by Primalsea View Post
    ....... just had a few issues due to age and a bit of bodging, but don’t we all!
    !!!!!!!

  3. #43
    Join Date: Sep 2012

    Location: London

    Posts: 272
    I'm Nick.

    Default

    the earth wire in the plug had come adrift, so any short could have resulted in a live chassis. And 600v could be fatal........
    We can definitely say it was in a shocking state

  4. #44
    Join Date: Oct 2016

    Location: London

    Posts: 47
    I'm David.

    Default

    So, work is well underway on this beast! I've got my head around the mindset of the previous modder. As they say, a little knowledge is a dangerous thing and as the previous modder would say 'a lot of Blue Tack is a good thing!' I've pulled out enough to run a sales conference for a fair-sized company!

    Apart from creating multiple ground loops in places, our modder made quite a few mods that nowadays you'd pick up from the internet, and applied them with pseudo knowledge and scant disregard for safety considerations. I'll be really interested to hear how this sounds once complete. I never thought I'd shed a tear for Maplins, but they were darn useful for sundry audio parts that now have to come from E Bay and Amazon.

    Sent from my ONEPLUS A5000 using Tapatalk

  5. #45
    Join Date: Nov 2013

    Location: HAMPSTEAD

    Posts: 423
    I'm brian.

    Default

    Good luck with it David. Hope you can fit me A/I 500 in at some stage over the next few weeks or so for repair/ service ?, no rush though. b w

  6. #46
    Join Date: Oct 2016

    Location: London

    Posts: 47
    I'm David.

    Default

    Thanks Brian and I could fit you in week after next if that works for you. The TT100 is all coming together now and will soon be ready for some testing. The modified power supply has all been ripped out and rebuilt to spec. Interestingly, the modder had converted the psu to choke input without changing the choke, resulting in a large voltage sag on the HT. In the original design, there is also a fuse carrying the 600v ht mounted on the chassis side, which I've now mounted internally as that was a bit of a safety hazard as somebody curious could simply unscrew the fuse holder cap and touch the live end of the fuse. Ouch! One of the 35 year old regulators had given up the ghost and so I've also rebuilt the driver stage power supply back to its original specification.

  7. #47
    Join Date: Nov 2013

    Location: HAMPSTEAD

    Posts: 423
    I'm brian.

    Default

    Thats great David, thanks. Confirm with you next week.

+ Reply to Thread
Page 5 of 5 FirstFirst ... 345



 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •