+ Reply to Thread
Results 1 to 9 of 9

Thread: Quad 34 Pre

  1. #1
    Join Date: Sep 2009

    Location: Bournemouth

    Posts: 4,285
    I'm Dan.

    Default Quad 34 Pre

    Hello Guys

    Well i was given one of these on the weekend but its not currently working hoping you can help...

    Powers Up the inputs are very erratic going from one to the other i have read on DADA that its the PCB that has gone i would like to get it repaired i have spoken to my tech will be booked in for a quote soon...only 1 channel working on Aux , Radio distorted ,

    Any thoughts?
    Main System
    Musical Fidelity E100 Amplifier & Mission 770 Freedom Speakers - Linn Interconnects & Van Den Hul Cables Speaker Cable..
    Vinyl :
    Rega Planar 2 / RB250 / Ortofon OM Super 10 / VDH Oil Bearing Upgrade / Roksan R Mat

    Second System:
    Technics 909U Pre / 909S Power Amplifiers / Celestion A1 Compact / Sony CD S1 / Thorens TD125 / SME 3009 / Shure V15 T2 / Cambridge Interconnects

  2. #2
    Join Date: Oct 2012

    Location: The Black Country

    Posts: 4,120
    I'm Alan.

    Default

    More than likely it is the quad analogue switch chips, 4066 or similar number.

    Had a similar scenario myself.

  3. #3
    Join Date: Jan 2009

    Location: Norwich

    Posts: 2,399
    I'm Hugo.

    Default

    The Quad 34 is lovely to look at and to use, but IME/IMO sounds poor even when freshly restored, so I recommend that you don't throw too much money at it. I know that some people will disagree and quote Peter Walker's well known marketing line about 'straight wire with gain' but the excellent Quad power amps were rather let down by preamps like the 34.

  4. #4
    Join Date: Apr 2012

    Location: Southall, West London

    Posts: 34,450
    I'm Geoff.

    Default

    I agree. I've used them. OK as a back-up, but the sound is lacklustre. If it can be sorted economically, fair enough, especially if it was a freebie.

  5. #5
    Join Date: Sep 2009

    Location: Bournemouth

    Posts: 4,285
    I'm Dan.

    Default

    Quote Originally Posted by Firebottle View Post
    More than likely it is the quad analogue switch chips, 4066 or similar number.

    Had a similar scenario myself.
    Hi Alan

    How are you? Do you have an idea of repair costs if this is the fault?

    Thank you..
    Main System
    Musical Fidelity E100 Amplifier & Mission 770 Freedom Speakers - Linn Interconnects & Van Den Hul Cables Speaker Cable..
    Vinyl :
    Rega Planar 2 / RB250 / Ortofon OM Super 10 / VDH Oil Bearing Upgrade / Roksan R Mat

    Second System:
    Technics 909U Pre / 909S Power Amplifiers / Celestion A1 Compact / Sony CD S1 / Thorens TD125 / SME 3009 / Shure V15 T2 / Cambridge Interconnects

  6. #6
    Join Date: Sep 2009

    Location: Bournemouth

    Posts: 4,285
    I'm Dan.

    Default

    Thank Hugo...
    Main System
    Musical Fidelity E100 Amplifier & Mission 770 Freedom Speakers - Linn Interconnects & Van Den Hul Cables Speaker Cable..
    Vinyl :
    Rega Planar 2 / RB250 / Ortofon OM Super 10 / VDH Oil Bearing Upgrade / Roksan R Mat

    Second System:
    Technics 909U Pre / 909S Power Amplifiers / Celestion A1 Compact / Sony CD S1 / Thorens TD125 / SME 3009 / Shure V15 T2 / Cambridge Interconnects

  7. #7
    Join Date: Sep 2009

    Location: Bournemouth

    Posts: 4,285
    I'm Dan.

    Default

    Quote Originally Posted by walpurgis View Post
    I agree. I've used them. OK as a back-up, but the sound is lacklustre. If it can be sorted economically, fair enough, especially if it was a freebie.
    I'm looking into it will be good as a back up not that i need it LOL.....Yes it was free....
    Main System
    Musical Fidelity E100 Amplifier & Mission 770 Freedom Speakers - Linn Interconnects & Van Den Hul Cables Speaker Cable..
    Vinyl :
    Rega Planar 2 / RB250 / Ortofon OM Super 10 / VDH Oil Bearing Upgrade / Roksan R Mat

    Second System:
    Technics 909U Pre / 909S Power Amplifiers / Celestion A1 Compact / Sony CD S1 / Thorens TD125 / SME 3009 / Shure V15 T2 / Cambridge Interconnects

  8. #8
    Join Date: Oct 2012

    Location: The Black Country

    Posts: 4,120
    I'm Alan.

    Default

    Hi Dan I'm fine, you too I hope. The cost of the chips is very little, they are equivalent or similar to this
    https://www.ebay.co.uk/itm/TEXAS-INS...wAAOSw-W5UtpqI

    Have a look on the board and see if you can see any chips with the number 4066 on them, I believe there are 4 from memory.


  9. #9
    Join Date: Sep 2009

    Location: Bournemouth

    Posts: 4,285
    I'm Dan.

    Default

    Quote Originally Posted by Firebottle View Post
    Hi Dan I'm fine, you too I hope. The cost of the chips is very little, they are equivalent or similar to this
    https://www.ebay.co.uk/itm/TEXAS-INS...wAAOSw-W5UtpqI

    Have a look on the board and see if you can see any chips with the number 4066 on them, I believe there are 4 from memory.

    Hi Alan

    Im very good thank you , I will pass these onto my technician - i had a look and their are 4 in their...

    Thank you...
    Main System
    Musical Fidelity E100 Amplifier & Mission 770 Freedom Speakers - Linn Interconnects & Van Den Hul Cables Speaker Cable..
    Vinyl :
    Rega Planar 2 / RB250 / Ortofon OM Super 10 / VDH Oil Bearing Upgrade / Roksan R Mat

    Second System:
    Technics 909U Pre / 909S Power Amplifiers / Celestion A1 Compact / Sony CD S1 / Thorens TD125 / SME 3009 / Shure V15 T2 / Cambridge Interconnects

+ Reply to Thread



 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •