+ Reply to Thread
Page 1 of 7 123 ... LastLast
Results 1 to 10 of 66

Thread: Help with my Tannoys

  1. #1
    Join Date: Dec 2015

    Location: Alicante. Spain.

    Posts: 1,608
    I'm Adrian.

    Default Help with my Tannoys

    Something weird has happened. I have the kensingtons and have been running them with the front controls set at Treble output Flat. Frequency cut off at +2db. All positions worked before but tonight I thought I'd drop the frequency cut off to flat - nada, no output on one speaker. I tried all positions - nada. Only the +2db is working. But they used to. What the hell has happened and how? Any ideas guys....

    Something happened last night which prompted my messing. I was playing Dead Can Dance Into the Labyrinth - final track Wind among the Barley and there was a buzzing in sympathy as a certain very very high note was sung. I put this down to end of side distortion and adjusted anti skate - I didn't recheck it. After all I was playing at around 25w and the tweeters are supposed to take huge amounts of power. And no way was the audio research into clipping.
    Technics SP10 mk2
    Jan Allaerts MC 1 Boron mk1 cart
    Miyajima Shilabe cart
    Hashimoto HM-X SUT
    Siggwan (gimballed not unipivot) Cocobola 12"
    Aurorasound Vida LCR Phonostage
    The Truth linestage
    Dave Slagle Autoformer Volume Controller
    Cary 805c SET amps
    Audio Note ANe-SPX speakers
    Townshend Isolda speaker cables
    Cardas Golden Presence interconnects

  2. #2
    Join Date: Apr 2012

    Location: Southall, West London

    Posts: 33,598
    I'm Geoff.

    Default

    Try some Deoxit on the treble adjusters.

  3. #3
    Join Date: Dec 2015

    Location: Alicante. Spain.

    Posts: 1,608
    I'm Adrian.

    Default

    Quote Originally Posted by walpurgis View Post
    Try some Deoxit on the treble adjusters.
    Just seems weird that all of them except the one I've been using have packed up. Can't believe my house is that mucky lol.
    Technics SP10 mk2
    Jan Allaerts MC 1 Boron mk1 cart
    Miyajima Shilabe cart
    Hashimoto HM-X SUT
    Siggwan (gimballed not unipivot) Cocobola 12"
    Aurorasound Vida LCR Phonostage
    The Truth linestage
    Dave Slagle Autoformer Volume Controller
    Cary 805c SET amps
    Audio Note ANe-SPX speakers
    Townshend Isolda speaker cables
    Cardas Golden Presence interconnects

  4. #4
    Join Date: Apr 2012

    Location: London

    Posts: 280
    I'm james.

    Default

    Are you saying one tweeter is playing up or the whole of the speaker?
    I would suggest a loose wire internally is more likely to explain the buzzing and silence than oxidation, though agree that cleaning the contacts can only help and is a sensible first step. If the oxidation built up on all the contacts exposed to air then only the one that was plugged (ie the one you had been using) would be last to suffer. But I thought this generation of Tannoys had gold plated plugs &c?

    Sent from my GT-I9195 using Tapatalk

  5. #5
    Join Date: Feb 2008

    Location: South Wales

    Posts: 6,561
    I'm NotTakingLifeTooSeriouslyTheseDays.

    Default

    Hi Adrian,
    If the high frequency unit is still working on the+2db, then I seriously doubt you have damaged it.
    Its probably something to do with the terminals behind the plate, just remove the plate and have a look behind to see if you can see anything obvious, I have had my Kensingtons for years and have run all sorts of amps through them including some high power ones, without a problem.
    Hope you get it sorted.
    Let me know if I can help further.
    A...
    Quote Originally Posted by farflungstar View Post
    Something weird has happened. I have the kensingtons and have been running them with the front controls set at Treble output Flat. Frequency cut off at +2db. All positions worked before but tonight I thought I'd drop the frequency cut off to flat - nada, no output on one speaker. I tried all positions - nada. Only the +2db is working. But they used to. What the hell has happened and how? Any ideas guys....

    Something happened last night which prompted my messing. I was playing Dead Can Dance Into the Labyrinth - final track Wind among the Barley and there was a buzzing in sympathy as a certain very very high note was sung. I put this down to end of side distortion and adjusted anti skate - I didn't recheck it. After all I was playing at around 25w and the tweeters are supposed to take huge amounts of power. And no way was the audio research into clipping.
    "Today scientists have substituted mathematics for experiments, and they wander off through equation after equation, and eventually build a structure which has no relation to reality"
    Nikola Tesla



    We Send our kids to school to be Educated, not Medicated!

  6. #6
    Join Date: Dec 2015

    Location: Alicante. Spain.

    Posts: 1,608
    I'm Adrian.

    Default

    Quote Originally Posted by anthonyTD View Post
    Hi Adrian,
    If the high frequency unit is still working on the+2db, then I seriously doubt you have damaged it.
    Its probably something to do with the terminals behind the plate, just remove the plate and have a look behind to see if you can see anything obvious, I have had my Kensingtons for years and have run all sorts of amps through them including some high power ones, without a problem.
    Hope you get it sorted.
    Let me know if I can help further.
    A...
    Will take a look behind the plate today if I find time.

    As for sound it sounds great - I can easily test the buzzing but am wary of it as am scared of finding a problem!
    Technics SP10 mk2
    Jan Allaerts MC 1 Boron mk1 cart
    Miyajima Shilabe cart
    Hashimoto HM-X SUT
    Siggwan (gimballed not unipivot) Cocobola 12"
    Aurorasound Vida LCR Phonostage
    The Truth linestage
    Dave Slagle Autoformer Volume Controller
    Cary 805c SET amps
    Audio Note ANe-SPX speakers
    Townshend Isolda speaker cables
    Cardas Golden Presence interconnects

  7. #7
    Join Date: Dec 2015

    Location: Alicante. Spain.

    Posts: 1,608
    I'm Adrian.

    Default

    Had the front control panel off - the crossover is sooooo complex and the biggest caps I've seen - but I cannot see anything wrong. Have emailed Tannoy in the hope I can speak to a techie.
    Technics SP10 mk2
    Jan Allaerts MC 1 Boron mk1 cart
    Miyajima Shilabe cart
    Hashimoto HM-X SUT
    Siggwan (gimballed not unipivot) Cocobola 12"
    Aurorasound Vida LCR Phonostage
    The Truth linestage
    Dave Slagle Autoformer Volume Controller
    Cary 805c SET amps
    Audio Note ANe-SPX speakers
    Townshend Isolda speaker cables
    Cardas Golden Presence interconnects

  8. #8
    Join Date: Apr 2012

    Location: Southall, West London

    Posts: 33,598
    I'm Geoff.

    Default

    My money is on dirty contact faces in the treble adjusters, especially as you say they work in one position.

    If you've got no access to Deoxit. Try alcohol but only use a little. Use cotton buds in the sockets and a bit of cotton wool or soft cloth on the pins. Make sure no cotton wool debris is left behind and never be tempted to use anything abrasive.

  9. #9
    Join Date: Dec 2015

    Location: Alicante. Spain.

    Posts: 1,608
    I'm Adrian.

    Default

    Quote Originally Posted by walpurgis View Post
    My money is on dirty contact faces in the treble adjusters, especially as you say they work in one position.

    If you've got no access to Deoxit. Try alcohol but only use a little. Use cotton buds in the sockets and a bit of cotton wool or soft cloth on the pins. Make sure no cotton wool debris is left behind and never be tempted to use anything abrasive.
    I cannot believe it. For all of them to be dead? And I mean dead - no crackle when jiggling the key into place, nada. The other speaker is fine. Same ambient exposure etc. I will try it.

    I cannot get in touch with Tannoy - it's a joke. Their online form asks for firmware version and software - as Compulsory Fields. Don't they make speakers - and bloody expensive speakers? I'd call them if i could find a bloody number - although I have music im not a happy bunny and need to understand what has happened.
    Technics SP10 mk2
    Jan Allaerts MC 1 Boron mk1 cart
    Miyajima Shilabe cart
    Hashimoto HM-X SUT
    Siggwan (gimballed not unipivot) Cocobola 12"
    Aurorasound Vida LCR Phonostage
    The Truth linestage
    Dave Slagle Autoformer Volume Controller
    Cary 805c SET amps
    Audio Note ANe-SPX speakers
    Townshend Isolda speaker cables
    Cardas Golden Presence interconnects

  10. #10
    Join Date: Feb 2010

    Location: Berkshire, UK

    Posts: 2,818
    I'm Tom.

    Default

    Quote Originally Posted by farflungstar View Post
    I cannot believe it. For all of them to be dead? And I mean dead - no crackle when jiggling the key into place, nada. The other speaker is fine. Same ambient exposure etc. I will try it.

    I cannot get in touch with Tannoy - it's a joke. Their online form asks for firmware version and software - as Compulsory Fields. Don't they make speakers - and bloody expensive speakers? I'd call them if i could find a bloody number - although I have music im not a happy bunny and need to understand what has happened.
    I've been trying to call Tannoy for a few days as well, all you get is some German woman with a recorded message, then regardless of what button you press it just rings out.

    Been trying to source a set of boxes for Eatons. In the old days if you called Coatbridge, someone in Coatbridge picked up the phone.
    Main: Speakers 'RFC' Tannoy Canterburys / custom crossovers; Amp - Radford STA100; Pre EAR 912; Vinyl: Thorens TD124 MkII + Ikeda IT345-CR1 / Ortofon 309 Limited tonearms; Cartridges Stereo - Miyajima Madake, Ortofon SPU Royal N + Shure M3D Jico stylus; Mono - Miyajimas - Zero 0.7, Premium 1.0 retipped by Ana Mighty Sound bamboo cantilever, Spirit '78' 3.0 conical from Ana, also vintage GE VRII, Shure M44 strapped for mono with several Expert Stylus conicals for different eras of 78s; Phono stage and SUT from EAR 912; Esoteric Sound Re-Equalizer for equalisation of early mono and 78, switchable in from tape loop; Digital: Audio Note CDT2/II transport, heavily modded AN Kit DAC + Mutec MC3+USB.

    Study: Speakers - Tannoy DC6; Amp: Duncan 'Tuberhunter' 200w class D; preamp - Pass DCB1; Vinyl: Garrard 401 with AT1503 tonearm and vintage SPU-GE; SUTs - Ortofon 2-15k & Bob's Devices; Phono Stage: Schiit Mani; Digital - Trichord Genesis III CDP + Arcam rBlink; Schiit Multibit DAC.

+ Reply to Thread
Page 1 of 7 123 ... LastLast



 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •