+ Reply to Thread
Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 48

Thread: Tonight's Amplifier Will Be

  1. #21
    Join Date: Apr 2012

    Location: Southall, West London

    Posts: 31,174
    I'm Geoff.

    Default

    Yes. I didn't mention the other speakers..................

  2. #22
    Join Date: May 2008

    Location: Surrey

    Posts: 5,926
    I'm Rob.

    Default

    As a famous comedian said..."there's more"
    Buy Bose...And get your parking validated!.

  3. #23
    Join Date: Apr 2012

    Location: Southall, West London

    Posts: 31,174
    I'm Geoff.

    Default

    Quote Originally Posted by walpurgis View Post
    Think I'll use the MingDa MC-9 TVC into a Monarchy Audio SM-70 Pro power amp and hook up the Tannoy Cheviot Mk.II's tonight. It's a great combo.
    Got it set up and warmed up. But there's distortion on one channel for some reason. I'll investigate!

  4. #24
    Join Date: Apr 2012

    Location: Southall, West London

    Posts: 31,174
    I'm Geoff.

    Default

    Quote Originally Posted by walpurgis View Post
    Got it set up and warmed up. But there's distortion on one channel for some reason. I'll investigate!
    Bugger! It's the SM-70 Pro power amp. Distorting on left channel and seems to be very hot above the power transformer rather than the heat sinks, as you would normally expect on a Class A amp. I've hardly used this since having a dodgy tranny replaced.

    I'll have to check it over. Maybe swap over the output from secondaries and see if the issue swaps channels.

    Got the basic SM-70 rigged up instead. Sounds very fine.

  5. #25
    Join Date: May 2008

    Location: Surrey

    Posts: 5,926
    I'm Rob.

    Default

    Bummer. I have been de-bugging a JLH 10w Dual Mono Class A I built some years ago, over the last couple of days as the L channel kept blowing the PCB fuse. Fixed the board and then had smoke from the L channel PS rectifier board! So I am now rebuilding that. R channel is fine.

    Hope you get it sorted.
    Buy Bose...And get your parking validated!.

  6. #26
    Join Date: Feb 2014

    Location: Huntingdonshire

    Posts: 1,413
    I'm Andrew.

    Default

    Quote Originally Posted by Puffin View Post
    As a famous comedian said..."there's more"
    And thats one for the kids!

  7. #27
    Join Date: Sep 2009

    Location: Bournemouth

    Posts: 4,149
    I'm Dan.

    Default

    Quote Originally Posted by walpurgis View Post
    Bugger! It's the SM-70 Pro power amp. Distorting on left channel and seems to be very hot above the power transformer rather than the heat sinks, as you would normally expect on a Class A amp. I've hardly used this since having a dodgy tranny replaced.

    I'll have to check it over. Maybe swap over the output from secondaries and see if the issue swaps channels.

    Got the basic SM-70 rigged up instead. Sounds very fine.
    Sorry to hear this Geoff Hope you get it sorted...
    Main System
    Musical Fidelity E100 Amplifier , Musical Fidelity E50 Tuner , Pioneer PDS 505 Precision CD Player , Pioneer PDS 703 CD Player , Acoustic Research AR20B Speakers Cables QED Strand 42 Speaker Cable , Linn Interconnects , Cable Talk , Cambridge Yellow Pacific..
    Vinyl -
    Rega Planer 2 with Rega Britain Green 250 Tonearm & Upgraded Van Den Hul Oil Bearing & Ortofon Super OM-10

    Second System:
    Technics - SU-C909U Pre-Amplifier & SE-A909S Power Amplifier & Technics ST-GT 1000 Tuner & Pioneer PDS 505 Precision player & Thorens TD-125 MK1 Turntable & SME 3009 Series 1 & Shure V15 Type II Cartridge & SME 2000 Plinth & Celestion A compact Speakers , Monster Speaker Cable , Cambridge Audio Atlantic Yellow Interconnects.

    Spare Kit
    Quad 33/303 , Creek 6060 , NAD 3020 Original , Cambridge P40 , Luxman 507X , Pioneer SA 6300 , Linn Tukan , Sony ES 308 , , Ariston RD40/80's Yamaha CR 820 , Sony TA 88 , Tannoy 615 MK2's

  8. #28
    Join Date: Apr 2012

    Location: Southall, West London

    Posts: 31,174
    I'm Geoff.

    Default

    Quote Originally Posted by dantheman91 View Post
    Sorry to hear this Geoff Hope you get it sorted...
    Think I've tracked down a suitable transformer, but I'll check it over before ordering bits. Just wondering if a decent SMPS could be an option. Need to locate my multimeters now. Not seen them for a year or two.

  9. #29
    Join Date: Feb 2013

    Location: W Lothian

    Posts: 39,793
    I'm Grant.

    Default

    I will use the Amps I always use coz that's all Ive got.

    Good to here you have an idea what's wrong Geoff
    Regards,
    Grant ....

    I've said it before and I'll say it again: democracy simply-doesn't-work
    .... ..... ...... ...... ................... ..... ..... ..... ..... .....
    OPPO BDP-103D DARBEE - JBE SERIES 3/M55 SAS/EMOTIVA XPS1 - TWIN PRO MONOBLOCK AMPLIFIERS - XIANG SHENG DAC\PRE\HEADPHONE AMP - AVANTREE OASIS CLASS 1 BLUETOOTH - AUDIO TECHNICA ATH-MSR7 & OPPO PM-3 PLANAR HEADPHONES - WIN10 JRIVER23, DEEZER HiFi - ECHO DOT - SMSL M6 MINIDAC - RPI/AUDIOPHONICS - FULL RANGE TWIN TELEFUNKEN/Q ACOUSTIC BT3/CANTON SUB - P.INSPIRED MAINS REGENERATED.

  10. #30
    Join Date: Apr 2012

    Location: Southall, West London

    Posts: 31,174
    I'm Geoff.

    Default

    Quote Originally Posted by struth View Post
    Good to here you have an idea what's wrong Geoff
    I've a fair idea mate. I'll try sorting it myself. I've enough others to use, so not stuck.

+ Reply to Thread
Page 3 of 5 FirstFirst 12345 LastLast



 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •