+ Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: A Little HELP From Members

  1. #1
    Join Date: May 2017

    Location: Cuckfield, Sussex, UK

    Posts: 37
    I'm Steve.

    Default A Little HELP From Members

    Not sure if this is the right area for this post, if not could one of the moderators please move to the correct area

    Hello fellow members,

    I’m seeking help and advice regarding the sound of my system –
    System comprises of -
    Project 2experience sb-dc - Oroton 2m silver
    Strathclyde STD305M – ADC ZLM
    Schiit Mani Phono Stage
    Cyrus CD8se
    Rega Brio 2017
    Dynaudio Emit20
    Inter connects are Klotz with Ms Audio rca and Audioquest Diamondback rca
    QED QT40 Speaker Cable


    My issue is this, The overall sound is really very good – tight bass fantastic mid (acceptable) treble but id like a little more sparkle at the top. My amp seems to drive the speakers with ease but the finer nuances of cymbals and hi hat seem a little lacklustre.
    Any advice on how to tackle the issue would be welcomed
    Not sure where to start E.g. speaker cable, interconnects, blah blah blah
    The vast knowledge of members here will I'm sure help sort my problem.

    Regards Steve…
    Last edited by STD305M; 16-11-2017 at 06:52.

  2. #2
    Join Date: Nov 2015

    Location: Wolverhampton

    Posts: 3,515
    I'm Oliver.

    Default

    Which bit isn't delivering? Digital or analogue?

    Sent from my EVA-L09 using Tapatalk
    Technics SP10 MK2 > Phonomac AT-1010 tonearm > ZYX R50 Bloom cartridge > Jolida JD9 MKII > Firebottle Monoblocks > Creek OBH-11SE Headphone Amp > IXOS Speaker Cables > Pioneer CS-77A Speakers

  3. #3
    Join Date: Apr 2009

    Location: Near Saffron Walden, Essex

    Posts: 5,322
    I'm Dave.

    Default

    Is this a new issue ? Is it with CD and both turntables ?

  4. #4
    Join Date: Apr 2008

    Location: Warrington

    Posts: 2,571
    I'm Neil.

    Default

    First off, speaker cables and interconnect changes are not going to give you what you need, so tread carefully here.

    What you are looking for is a more fundamental change... what stands are you using with your speakers, and are you using spikes? How is your turntable set up i.e. is it on a rack or wall-shelf, is it decoupled? What rack are you using, if any? Often, a different approach to setting up components e.g. with coupling or decoupling techniques can give you what you need without having to change components.
    Mana Acoustics Racks >> Custom Silent Media Server >> Halide Bridge USB (with AQVOX USB power) >> Pedja Rogic's Audial Model S DAC + Pioneer PL-71 turntable / Vista Audio phono-1 mk II / Denon PCL-5 headshell / Reson Reca >> LFD DLS >> LFD PA2M (SE) >> Royd RR3s.

  5. #5
    Join Date: Oct 2012

    Location: Lutterworth, Leicestershire, UK

    Posts: 9
    I'm Adrian.

    Default

    You may find a cheap set of supertweeters are worth a go. I have a pair stacked on my Mission 750's and they helped define the base and added to the top end and placement. I would not be without them albit I expect somebody else would find everything a bit bright. Having said that those Dynaudio should not be lacking anything particularly with the Cyrus CD. Adrian.

  6. #6
    Join Date: May 2017

    Location: Cuckfield, Sussex, UK

    Posts: 37
    I'm Steve.

    Default A Little HELP From Members

    Hi,
    The sound is the same from all sources, My speakers are mounted on Partington Dreadnoughts and the issue has been there since day one.
    Both the turntables are on racks with one on a thick wooden plinth and one on a granite plinth.
    Im begining to wonder if I need to change the amp or speakers as Ive already tried various combinations of cables and different locations for the speakers???


    Any Thoughts would be welcome

    Regards Steve...











    hi

  7. #7
    Join Date: May 2017

    Location: Cuckfield, Sussex, UK

    Posts: 37
    I'm Steve.

    Default

    Thanks Adrian, the only issue is the very top end - otherwise im quite happy with the sound .
    I just feel the system should be giving more!!!!

  8. #8
    Join Date: Feb 2013

    Location: W Lothian

    Posts: 37,875
    I'm Grant.

    Default

    could try a different speaker cable. supertweeter maybe too. If you have an aquaintance borrow their speakers and see if any difference. they are quite small so depends too on the room
    Regards,
    Grant ....

    I've said it before and I'll say it again: democracy simply-doesn't-work
    .... ..... ...... ...... ................... ..... ..... ..... ..... .....
    DENON DV2900 - TWIN PRO MONOBLOCK AMPLIFIERS - XIANG SHENG DAC\PRE\HEADPHONE AMP - AVANTREE OASIS CLASS 1 BLUETOOTH - AUDIO TECHNICA ATH-MSR7 & OPPO PM-3 PLANAR HEADPHONES - WIN10 JRIVER23, SPOTIFY PREMIUM - ECHO DOT - SMSL M6 MINIDAC - FULL RANGE TWIN TELEFUNKEN's - Q ACOUSTIC BT3 actives - CANTON SUB - MAINS REGENERATED AND FILTERED.

  9. #9
    Join Date: May 2017

    Location: Cuckfield, Sussex, UK

    Posts: 37
    I'm Steve.

    Default

    Thanks Grant
    I don't have anyone nearby i could borrow and try another pair of speakers from.
    So far i have tried 3 different sets of speaker cables with no success also half a dozen pairs of interconnects which will now have to be sold as no difference

    Regards Steve

  10. #10
    Join Date: Apr 2016

    Location: Berwick-upon-tweed, Northumberland, UK

    Posts: 3
    I'm Naassan.

    Default

    Silver speaker cables can help a bit as they tend to better pass hug frequencies.
    Have a look on Chord Odyssey cables.

    Sent from my Plus E using Tapatalk

+ Reply to Thread
Page 1 of 3 123 LastLast



 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •