+ Reply to Thread
Results 1 to 3 of 3

Thread: Bushmaster Mk1 headphone output not working

  1. #1
    Join Date: Mar 2014

    Location: West Wales

    Posts: 78
    I'm malcolm.

    Default Bushmaster Mk1 headphone output not working

    I've just become the owner of a Bushmaster Mk1 (unmodified) DAC works fine and sounds great but the headphone output is pretty much dead, plugging phones in cuts the RCA output but only an extremely quiet sound of music can be heard on full volume, I've opened it up but can't see anything obviously untoward. Question is - where should I start looking, are there any easy tests I can carry out?
    malcolm ("You can't shine if you don't burn" - Kevin Ayers)

    If what I'm hearing is colouration, then bring on the whole rainbow

  2. #2
    Join Date: Feb 2008

    Location: http://www.homehifi.co.uk

    Posts: 6,020

    Default

    The most likely cause is either the headphone socket or the headphone amp output current buffer IC. You would need a scope to see which one it is. PM or email me if you would like me to have a look at it for you.

  3. #3
    Join Date: Mar 2014

    Location: West Wales

    Posts: 78
    I'm malcolm.

    Default

    All sorted now thanks to Stan's help. What a great guy to deal with, I wish all manufacturers cared as much as he does. I now have a fully functioning unit complete with Venum and Serum mods and upgraded firmware - sounding fantastic.
    malcolm ("You can't shine if you don't burn" - Kevin Ayers)

    If what I'm hearing is colouration, then bring on the whole rainbow

+ Reply to Thread



 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •