+ Reply to Thread
Results 1 to 6 of 6

Thread: Ortofon Quality control?

  1. #1
    Join Date: Apr 2017

    Location: Bristol

    Posts: 41
    I'm Tony.

    Default Ortofon Quality control?

    Has anyone got any recent experience of Ortofon MC's?

    I picked one up yesterday, a Quintet Bronze and as soon as I took it out of the box I could see the cantilever was leaning to the left.

    I took it back to the dealer who agreed to send it back to Henley Designs for replacement.

    I'm just concerned that I may end up with another dud!

    Anyway, I plan to open the next one in the store...
    VPI Scout 1.1, Ortofon Quintet Bronze, Trigon Vanguard I, SB Touch, AD Audio Modded Yaquin MC13S and Totem Arro.

  2. #2
    Join Date: Jan 2013

    Location: Birmingham

    Posts: 2,859
    I'm James.

    Default

    Yep had a poor quality 2M black recently but Ortofon did replace it after 4 weeks!
    Lenco GL75 / Shure M55e / Jico SAS /VPI Scout 1.1 / JMW 9T Tonearm / 2M Black /Croft 25R+ / Croft 7 / Spendor SP2

  3. #3
    Join Date: Nov 2008

    Location: Belfast/Northern Ireland/UK

    Posts: 15,624
    I'm Neil.

    Default

    You will be entitled to a refund if the next is bad, as you were with the first one.

    Michael Fremer once wrote an article about cantilever alignment and the poor QC he was seeing in many companies cartridges. I have looked for it but haven't been able to find it again.
    Last edited by Dalek Supreme D L; 19-05-2017 at 14:38.
    Regards Neil

  4. #4
    Join Date: Mar 2016

    Location: Brighton, UK.

    Posts: 97
    I'm Mike.

    Default

    I often wonder whether shops - highstreet and online just sell used ones.

  5. #5
    Join Date: Apr 2011

    Location: London

    Posts: 2,514
    I'm Robert.

    Default

    Ortofon shift silly amounts of units so my thinking is there'll be the odd one..I've had at least 5 different Ortofon's, never had a dud
    There customer service is good I'm led to believe

  6. #6
    Join Date: Jul 2013

    Location: Kingsbury, NW London

    Posts: 971
    I'm Clive.

    Default

    I had the same problem with a Cadenza Bronze. Henley Designs replaced without issue. I've since moved the Bronze on and replaced with a Cadenza Black.
    SOURCE:Cyrus Phono Signature+PSX-R,Cyrus StreamXSignature,Cyrus CDXtSignature, OPPO UDP-205 BluRay, SkyHD, Technics SL1210M5G/Achromat/MN Bearing/Isonoes with Boots/Origin Live Encounter Mk3A/Ortofon Cadenza Black or Hana SL or AT33PTG/II
    AMPLIFIER: Cyrus DAC XP Signature+PSX-R2, 2 x Cyrus Mono X300 Signature
    SPEAKERS: Spendor D7.
    HEADPHONES OPPO PM-1 with Atlas Zeno cable, Arcam rHead, OPPO PM-3 with Atlas Zeno cable, Atomic Floyd TwistJax, Chord Mojo.
    CABLES: Analogue: Speaker - Chord Signature. Interconnect - Atlas Mavros XLR, Chord Shawline XLR, Chord Indigo Tuned ARAY, Chord Indigo Plus.
    Digital: Missing Link Binary Star x2, Cyrus Digital, Chord Optichord.
    Mains: Chord Power Chord x5, Homemade SupraLoRad 1.5/MK/Wattgate x5, IsoTek Orion 6 way, Sounds Fantastic 6way Mains Blocks.
    STORAGE Synology DS216J NAS with 2 x 3Tb WD Red hard-drives

+ Reply to Thread



 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •