+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: PSVANE

  1. #11
    Join Date: Sep 2014

    Location: Northern Ireland

    Posts: 355
    I'm John.

    Default

    Think the Primaluna branded valves are made by Shuguang.

  2. #12
    Join Date: Dec 2015

    Location: Alicante. Spain.

    Posts: 286
    I'm Adrian.

    Default

    Have you swapped positions to be sure it's the valve...

    Adey

    Sent from my Aquaris E4.5 using Tapatalk

  3. #13
    Join Date: Dec 2008

    Location: Lincolnshire, Home by the Sea

    Posts: 3,026
    I'm Shaun.

    Default

    Quote Originally Posted by farflungstar View Post
    Have you swapped positions to be sure it's the valve...

    Adey

    Sent from my Aquaris E4.5 using Tapatalk
    No man, I haven't swapped valves around I have replaced them completely with the original valves and the problem has disappeared.
    Marantz CD6005 into an Audiolab M-DAC
    Stanton ST150 turntable and Benz Micro Silver HOMC
    Prima Luna Prologue 3 preamplifier with phono stage
    Prima Luna Dialogue Premium power amp EL34
    KEF Q500 loudspeakers
    Mark Grant VDC single wired loudspeaker cables
    Atlas Hyper MkII interconnects

  4. #14
    Join Date: Feb 2014

    Location: Huntingdonshire

    Posts: 976
    I'm Andrew.

    Default

    Get you some vintage British valves in that pre Shaun. Best money I've spent in a long while. Lush with bags of new detail.

  5. #15
    Join Date: Feb 2016

    Location: Chesterfield

    Posts: 52
    I'm Tim.

    Default

    Quote Originally Posted by CornishPasty View Post
    Can't comment on the small bottles but I bought a matched quad of their 211s a while ago and I really do like them, enough to persuade me to try some of their other valves in the future.
    Hi
    Which of the range of 211's did you buy?
    I'm considering a pair of T11's for my amp.
    What are your thoughts on the PSvane 211's
    Thanks

  6. #16
    Join Date: Feb 2008

    Location: Near Accrington, Lancs, UK

    Posts: 235
    I'm Ralph.

    Default

    Spider, I bought a matched quad of the HiFi Series 211s. I didn't realise until I dug out the receipt this morning that I bought these mid 2013. When I first put them in I remember an increase in volume and a more open sound compared to the old tubes. I've put quite a few hours on these Psvanes and I'm more than happy with them. They haven't missed a beat.
    Ralph.

  7. #17
    Join Date: Nov 2012

    Location: North Bham - West Mids

    Posts: 58
    I'm Manny.

    Default

    Quote Originally Posted by Haselsh1 View Post
    LOL... I have now had these since Christmas and there is already a major problem. On turning the volume down almost to zero there is now a large hum or buzz through the loudspeakers that disappears when the volume is turned back up. I have re-fitted the original Prima Luna valves and hey presto, no problem.
    When you get a moment, if you could narrow it down by swapping out the valves one by one? Maybe one of the valves wasn't sitting right, loose in it's base?

+ Reply to Thread
Page 2 of 2 FirstFirst 12



 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •