+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Possible issue with some Wharfedale W4 Loudspeakers

  1. #11
    Join Date: Apr 2012

    Location: Southall, West London

    Posts: 34,469
    I'm Geoff.

    Default

    Quote Originally Posted by dantheman91 View Post
    Guys been offered a pair of these local for a sensible price i may have to wait to payday for they seen very good value to add to the collection...

    Watch this space...
    I'd not pay a fortune for those Dan. You'll find the sound somewhat 'vintage' and the power handling will not be great, but that is offset to an extent by the high efficiency.

  2. #12
    Join Date: Sep 2009

    Location: Bournemouth

    Posts: 4,286
    I'm Dan.

    Default

    Quote Originally Posted by walpurgis View Post
    I'd not pay a fortune for those Dan. You'll find the sound somewhat 'vintage' and the power handling will not be great, but that is offset to an extent by the high efficiency.
    Their 100 - Maybe worth a try....
    Main System
    Musical Fidelity E100 Amplifier & Mission 770 Freedom Speakers - Linn Interconnects & Van Den Hul Cables Speaker Cable..
    Vinyl :
    Rega Planar 2 / RB250 / Ortofon OM Super 10 / VDH Oil Bearing Upgrade / Roksan R Mat

    Second System:
    Technics 909U Pre / 909S Power Amplifiers / Celestion A1 Compact / Sony CD S1 / Thorens TD125 / SME 3009 / Shure V15 T2 / Cambridge Interconnects

+ Reply to Thread
Page 2 of 2 FirstFirst 12



 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •