Tab Content
More Activity

3 Visitor Messages

  1. View Conversation
    hi james,
    just want to ask the condition of the amp as far as sound is concerned.
    any noise, hum or audible distortion?
    thanks,
    jorge
  2. Hi Julian,
    thanks for the advice, indeed I have been trying to find a Qad specialist to service my amp and was going to send it to Fidele audio but they seem to have stopped operating as a business.

    With regards to th mains block I am quite sceptical at the possibilities of any sound improvement, however i think i could do with one without switches and lights which I am sure add some intereference?

    Cheers
  3. View Conversation
    If it's coming from just one channel that to me would suggest it has nothing to do with the mains but is an issue with one of your components. If you don't have any valve gear your Quad 606 will be the most likely culprit IMO - have you had it serviced recently? If you haven't you might be surprised how much you can improve its sound quality by getting it serviced at a Quad specialist. If you haven't done it already, you can quickly rule out the speakers just by swapping them over and see if the buzz is still in the same channel.

    If you do buy a mains block, make sure you buy from somewhere that will do returns if you're not happy with it - very possible that you'll end up with a beautifully made mains block that looks the business, but does bollock all for the sound!

    Good luck.
Showing Visitor Messages 1 to 3 of 3
About Jimbo

Basic Information

About Jimbo
Name:
James
Location::
Birmingham
Interests::
Cycling Food Hifi - not necessarily in that order!

Signature


VPI Scout 1.1 / JMW 9T Tonearm / 2M Black /Croft 25R+ / Croft 7 / Spendor SP2

Statistics


Total Posts
Total Posts
3,219
Posts Per Day
1.78
Visitor Messages
Total Messages
3
Most Recent Message
20-03-2015 10:25
General Information
Last Activity
Today 18:22
Join Date
05-01-2013